WotC_FrankF#52204

My feedback

  1. 7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    An error occurred while saving the comment
    WotC_FrankF#52204 commented  · 

    Tibalt's Ruse does not activate for use against my own spells. He won't let me use it. I spent a lot of jokers to get this deck and once I have it I can't use it. But my opponents can beat me ranked matches with her. It doesn't seem fair to me. Can anyone fix it?

  2. 8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  MTG Arena Bugs & Product Suggestions » Store  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    WotC_FrankF#52204 commented  · 

    I've been looking to spend money in the store and have seen information online that I should have a new player bundle available to me. I don't see it in the store and wondering if it's something wrong with my account.

  3. "Maximum hand size is 0" / cards not drawn / no library / negative life totals

    428 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    An error occurred while saving the comment
    WotC_FrankF#52204 commented  · 

    I’ve taken photos and explained the bug.
    I was at -4 and we were continuing to play.
    Was not a able to draw
    So I’ve as asked you compensation

  4. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    An error occurred while saving the comment
    WotC_FrankF#52204 commented  · 

    I lose connection during my matches, and this only happens for MTG Arena. My other games have no problem with connection. I've tried flushing the dns and followed the other steps in your troubleshooting guide. I noticed this was a fairly common issue before and I want to know if there is a definite solution to this.

    I've tried all of the troubleshooting with no changes, still disconnects frequently.
    However, I did try running the game through a VPN and it has been stable.
    I'm not sure why that would be the case though, has this happened to anyone else?

Feedback and Knowledge Base