Mr.Domino#81492

My feedback

  1. 147 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    Mr.Domino#81492 commented  · 

    Sadly, I fear only 15 (now 16) comments and 125 votes in a year's time won't result in much thought being put to a native Linux port.

    Mr.Domino#81492 supported this idea  · 
    An error occurred while saving the comment
    Mr.Domino#81492 commented  · 

    Yes, please. Linux support would go a long way to getting this game to a more diverse audience.

  2. 259 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    Mr.Domino#81492 commented  · 

    After updating Arena has become borderline unplayable due to the amount of lag and stuttering that occurs on any action taken. For example, if I play shockland, the game will momentarily freeze for sometimes 10-15 seconds before prompting me whether I'd like for the land to enter tapped or pay the 2 life, and this is happening with every card I play now. This results in constantly having the timer start running down on my turn and an inability to bank any extra timeouts so on turns when I have more than 2 plays, I will often have my turn abruptly end without finishing my selections or castings which leads to having lost several games because of this issue! I am CERTAIN it is NOT a hardware issue on my end as I am running an i7 3930k with a GTX 1080 and 32 GBs of RAM with the game installed directly on an SSD RAID 0 Array, so performance should not be an issue, especially considering that I can run nearly ANY high-end AAA game without a hitch. I've not experienced ANY issues like these in Arena until very recently since the last update. In my experience with these issues it seems to be some kind of server side issue, because I am constantly getting a "Waiting for the server" message just going changing screens on the main menu (i.e. Going from "Home" to "Profile" or "Decks" results in that message and the spinning circle, even if I'm already on the Home screen and just hit "Play" it will give me the Waiting for the Server message for 5-10 seconds before going to the matchmaking screen to wait for an opponent to be found.) I've tried opening all the TCP ports as described on the Troubleshooting page as well as restarting and closing all background applications but nothing has corrected these issues. I don't know if both issues in-game and in-menus are coorelated but it feels like they are. Anyway, thank you for taking the time to look into this and please resolve it as soon as possible, because with these issues the game is nearly unplayable!

    Mr.Domino#81492 supported this idea  · 

Feedback and Knowledge Base