Skip to content

Biiks#85358

My feedback

3 results found

  1. 149 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    Biiks#85358 commented  · 

    Same for daily quest is stuck at 25/30 Blue Green spells cast

    Biiks#85358 supported this idea  · 
  2. Obtained cards tagged as new but were already owned

    217 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    Biiks#85358 commented  · 

    i opened a couple packs and multiple times i got hatching plans showing up as my first even though i already had a set of four, the same bug happened with lord skitter which i had one of but still showed first, i dont think i got vault progression for the hatching plans either

    Biiks#85358 supported this idea  · 
  3. 88 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    Biiks#85358 commented  · 

    this is the screenshot of the place where i got stuck with internet

    An error occurred while saving the comment
    Biiks#85358 commented  · 

    i disconnected while i had the full use of my internet, it just randomly happened during a premier draft where i couldnt concede either, which i also recieved a loss for. If i could get my money back that would be great (I took some screenshots of this but i cant attach them for whatever reason, im also trying to attach the correct logs but im not sure how to do it so it might be wrong)

    Biiks#85358 supported this idea  · 

Feedback and Knowledge Base