Skip to content

neurosoup#90259

My feedback

5 results found

  1. 1,016 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    neurosoup#90259 commented  · 

    This issue started for me about a month ago, same time as the original post. Since then I haven't been able to play against my partner. Any direct match has the issue where it seems to start for one of us (we go into the waiting room) but the other person gets the spinning wheel and "waiting on server" until it times out. We have tried many, many times over the past month and this happens every time. It doesn't matter which one of us initiates the direct challenge or which device we play on (we have tried on android, iphone, mac, and windows, and every combination of pairing between those). Direct matches are the only reason they have an account and spend any money on it. It's been incredibly frustrating that we bought cards but haven't been able to use them against each other for the past two sets (WOE and LCI). Wizards, you need to fix this ASAP, it is a major functionality of your game that people spend money on that is just completely broken. Unacceptable.

    neurosoup#90259 supported this idea  · 
  2. 117 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    neurosoup#90259 supported this idea  · 
  3. Can't Edit Draft/Sealed Decks

    1,430 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    neurosoup#90259 supported this idea  · 
  4. 2,697 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    neurosoup#90259 commented  · 

    This is happening to me like others have described, and I have tried on windows, mac, and android versions. Happens on all three. In addition to the quests and daily/weekly wins circles not showing up, perhaps the more frustrating part is that the friends list also disappears, and I cannot initiate or accept direct challenges. On my friend's account, I show up as being online, and they can initiate a direct challenge to me, but I cannot accept it because the "person" icon is simply not there in the bottom left of the screen. It looks like this is also the case with many of the screenshots posted by others below.

    neurosoup#90259 supported this idea  · 
  5. 611 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    neurosoup#90259 supported this idea  · 
    An error occurred while saving the comment
    neurosoup#90259 commented  · 

    This is happening to me like others have described, and I have tried on windows, mac, and android versions. Happens on all three. In addition to the quests and daily/weekly wins circles not showing up, perhaps the more frustrating part is that the friends list also disappears, and I cannot initiate or accept direct challenges. On my friend's account, I show up as being online, and they can initiate a direct challenge to me, but I cannot accept it because the "person" icon is simply not there in the bottom left of the screen. It looks like this is also the case with many of the screenshots posted by others below.

    Side note, the reason I have not attached a log file is because the "capture log" button does literally nothing for me at the moment, on macOS. After clicking "report a bug", the screen comes up with the "capture log" button, but clicking on that does nothing.

Feedback and Knowledge Base