Skip to content

iCedfR0g23#31902

My feedback

4 results found

  1. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    iCedfR0g23#31902 shared this idea  · 
  2. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    iCedfR0g23#31902 shared this idea  · 
  3. 97 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    iCedfR0g23#31902 commented  · 

    This is my 2nd midweek magic with preview of individual card rewards on win. I checked my collection if there were new card received which usually appear in the beginning part but nothing was received

    iCedfR0g23#31902 supported this idea  · 
  4. Obtained cards tagged as new but were already owned

    215 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    iCedfR0g23#31902 commented  · 

    When I open my packs, the system is tagging some of the cards as "FIRST" copies, when in fact I already previously received multiple copies of the cards in my collection

    Pls see my screenshots, 1st image shows the cards tagged as first copies. The 2nd and 3rd images shows that I already have them

    I noticed this when there was a change in the animation of opening of packs. As far as I know, this did not happen on March of machines

    Pls fix the bug. It gives a false impression to the player

    Thank you!

    iCedfR0g23#31902 supported this idea  · 

Feedback and Knowledge Base