Skip to content

blademaster0182#34056

My feedback

2 results found

  1. 131 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    blademaster0182#34056 commented  · 

    Same issue here. Just started this morning. I got one match in after a full reboot. This is causing me to climb down the ladder which is annoying. It also means I can't play this game

    blademaster0182#34056 supported this idea  · 
  2. 4,644 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    blademaster0182#34056 commented  · 

    I am also having this issue. It has been ongoing since the Sept 4th update. I was crashing every 3 or so games, often as I entered a match or as something was resolving. I opened a ticket with support (ticket ID #851729). They had me perform a number of steps and ultimately sent this up to the devs. They told me to submit future issues here.

    I was able to suffer through the issues by restarting after my third game. I however could not play on my main profile as I was stuck in a "Checking for Updates" loop. Playing on a new profile was the only workaround that worked.

    After the Sept 26th update, the crashing has increased. I now crash every game, often as I'm joining. If not, then it will crash in the middle of the match. I did a clean uninstall, per the instructions given to me in my ticket and I used Revo Uninstaller to do it (also recommended by WotC support). This did not resolve the issue.

    Since this issue has started, I have taken every step outlined in the support ticket multiple times. I have also wiped and rebuilt my computer with a fresh installation of Windows 10. Nothing has helped.

    Please let me know if there any logs you need from me.

    blademaster0182#34056 supported this idea  · 

Feedback and Knowledge Base