Skip to content

JustCallMeSPED#62110

My feedback

7 results found

  1. Obtained cards tagged as new but were already owned

    226 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    JustCallMeSPED#62110 commented  · 

    Exactly as the title says: I open a pack, and cards that I know I already have in my collection are getting the little "First" tag on them.

    JustCallMeSPED#62110 supported this idea  · 
  2. 5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    An error occurred while saving the comment
    JustCallMeSPED#62110 commented  · 

    As I stated in my original post, I went there first and tried everything in that post to no avail.

    An error occurred while saving the comment
    JustCallMeSPED#62110 commented  · 

    For about a week now, my Arena client has repeatedly lost connection to the server during normal use. The "Waiting for Server" icon appears no matter what I am doing: Deck building, in matches, attempting to join a match, checking out the store, simply signing in. I have already tried all of the "Performance Issues" suggestions, including restarting my device AND my router. I basically cannot go more than a minute in a match without losing connection, which then takes another minute to reestablish, at which point I have already missed my turn and am several turns behind.

    Device: OnePlus 11
    OS: Android 11
    Reproduce: Just normal play

    EDIT: I just tried to uninstall and reinstall Arena, thinking maybe something got corrupted. The server drops are happening even during the initial 2GB+ download after you first launch and sign in. I get great download speeds for 30 seconds or so, followed by "Waiting for Server". This isn't an issue with my Wifi, either. I've used several network monitoring tools to ensure that I am not experiencing disconnections in my wireless internet connection, and I can stream hi-def videos no problem. This specifically seems to be connection issues with the MtG Arena server.

    JustCallMeSPED#62110 supported this idea  · 
  3. 4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    JustCallMeSPED#62110 supported this idea  · 
  4. 39 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    JustCallMeSPED#62110 supported this idea  · 
  5. 54 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    JustCallMeSPED#62110 supported this idea  · 
  6. 23 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    JustCallMeSPED#62110 supported this idea  · 
  7. 146 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    JustCallMeSPED#62110 supported this idea  · 

Feedback and Knowledge Base